EatTheBlocks Forum

Day 14 Multisig wallet is not functioning properly

I tried executing the existing code of multisig wallet, but it seems that the web3 provider is not working. Please find below snapshot image

Even though if I manage to get the UI up and running, still its not able to send wei to mentioned account image

Also i am getting React warning on missing dependencies.

Please help me out in resolving the issue.

It seems that event listener in Util.js is not being invoked properly, as the load event has fired already before the components are being instantiated.

Julien, do I need to make any changes to the code ?

If I just remove the event listener, it works fine

I just tried the code in the git repo, it works.

Are you on the correct network? Are accounts reset? Have you reloaded the page and clear the browser cache? Are you using a modern version of chrome?

(a lot of things can go wrong with Metamask…)

Yes i tried those its still not working :confused:
I think metamask is working fine, its the load event listener which is causing this problem.

mmm… I am unable to reproduce the bug :frowning:

You mentioned if you remove the load event listener it works…
maybe just do that?

1 Like

Yes… I have kept it that way.

1 Like