EatTheBlocks Forum

Getting a "failed to meet quorum" error

Hello, I ran “node run-arbitrage.js” after successfully deploying to mainnet and I am getting "(node:36607) UnhandledPromiseRejectionWarning: Error: failed to meet quorum (method=“getBlockNumber”. I’m not really sure what this mean, some help please.

Here is the full error:

what happen if you keep running the script? do you see this error again?
did you see this error at the beginning of running the script or after some time?

hey @jklepatch I see this as soon as I run the command, I even recloned and same error. I know some others are running into this error too from the discord

It seems to be an error with the Ethers library, fixed by newer versions, which is used behind the hood by the Uniswap SDK. Try upgrading the Uniswap SDK to the latest version of the 2-x branch (2.0.6)

npm uninstall @uniswap/sdk
npm install @uniswap/sdk@2.0.6

Hi. I am having the same error and I am using Uniswap SDK 2.0.6… the script runs well for a while, then the error occurs and goes back to normal.

Did you find a way to fix this?

it appears this is a bug in the ethers (a library used by the Uniswap SDK).
You can try to update the Uniswap SDK to a newer 2.x version.
Alternatively you can restart the script from time to time automatically when there is this error. I need more time to think about how to do it.

1 Like