EatTheBlocks Forum

I'm having this issue on deployment


 truffle migrate --network mainnet --reset

Compiling your contracts...
===========================
> Everything is up to date, there is nothing to compile.



Migrations dry-run (simulation)
===============================
> Network name:    'mainnet-fork'
> Network id:      1
> Block gas limit: 15000000 (0xe4e1c0)


1_initial_migration.js
======================

   Deploying 'Migrations'
   ----------------------
   > block number:        12593615
   > block timestamp:     1623151896
   > account:             0x713545773321F11cB1714153d2cdd8524E5e2659
   > balance:             0.037994778
   > gas used:            176931 (0x2b323)
   > gas price:           2 gwei
   > value sent:          0 ETH
   > total cost:          0.000353862 ETH

   -------------------------------------
   > Total cost:         0.000353862 ETH


2-deploy-contracts.js
=====================

   Deploying 'Flashloan'
   ---------------------
   > block number:        12593617
   > block timestamp:     1623151901
   > account:             0x713545773321F11cB1714153d2cdd8524E5e2659
   > balance:             0.033583606
   > gas used:            2178248 (0x213cc8)
   > gas price:           2 gwei
   > value sent:          0 ETH
   > total cost:          0.004356496 ETH

   -------------------------------------
   > Total cost:         0.004356496 ETH


Summary
=======
> Total deployments:   2
> Final cost:          0.004710358 ETH





Starting migrations...
======================
> Network name:    'mainnet'
> Network id:      1
> Block gas limit: 15000000 (0xe4e1c0)


1_initial_migration.js
======================

   Deploying 'Migrations'
   ----------------------


Error:  *** Deployment Failed ***

"Migrations" could not deploy due to insufficient funds
   * Account:  0x713545773321F11cB1714153d2cdd8524E5e2659
   * Balance:  38348640000000000 wei
   * Message:  insufficient funds for gas * price + value
   * Try:
      + Using an adequately funded account
      + If you are using a local Geth node, verify that your node is synced.

    at /usr/local/lib/node_modules/truffle/build/webpack:/packages/deployer/src/deployment.js:365:1
    at processTicksAndRejections (internal/process/task_queues.js:85:5)
Truffle v5.3.9 (core: 5.3.9)
Node v12.8.1

Ok so I added more money and it went through but now I’m getting this message. So the question is, how do I make it so the transaction gets processed faster?

[code] Saving migration to chain.

Error: Transaction was not mined within 750 seconds, please make sure your transaction was properly sent. Be aware that it might still be mined!
at Migration._deploy (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:104:1)
at processTicksAndRejections (internal/process/task_queues.js:85:5)
at Migration._load (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:61:1)
at Migration.run (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:218:1)
at Object.runMigrations (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/index.js:150:1)
at Object.runFrom (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/index.js:110:1)
at Object.runAll (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/index.js:114:1)
at Object.run (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/index.js:79:1)
at runMigrations (/usr/local/lib/node_modules/truffle/build/webpack:/packages/core/lib/commands/migrate.js:258:1)
at Object.run (/usr/local/lib/node_modules/truffle/build/webpack:/packages/core/lib/commands/migrate.js:221:1)
at Command.run (/usr/local/lib/node_modules/truffle/build/webpack:/packages/core/lib/command.js:147:1)
Truffle v5.3.9 (core: 5.3.9)
Node v12.8.1
[/code]

There is a way to allow truffle to go more than 750 seconds. However most of us have just increased gas price to allow for a quicker transaction.

1 Like

Hi batman can you tell me in the code exactly where I can achieve increasing gas and how much increase is suggested?

beware how much gas you put to it. I had a deploy cost 400 dollars and fail before it was done because it ran out of gas. I would be interested in how to force truffle to run more than 750 seconds. Or what settings work to get the contract fully deployed at a cheaper price. there is also an update coming to the flashloan course that might help you can check out my questions thread here

Just now I tried to deploy and I got the same error.

As mentioned in the course, I transferred $ 30 worth ETH :rofl: to the address and assumed everything would go well.

Shocking to know even after spending $ 400, @brocoflower79 couldn’t deploy. Thank you so much for the heads-up!

Now my only choice is to wait for the updated BSC code.

@Batman Any idea when BSC code would be released ? Thanks in advance.

@duneglow i think i have it figured out you want your mainnet code in the truffle-config.js file to look something like this
mainnet: {
gasPrice: 7500000000,
websockets: true,
provider: () => new HDWalletProvider(
process.env.PRIVATE_KEY,
process.env.INFURA_URL
),
network_id: 1, //mainnet
production: true
},
I ran this at 8:15 am est when the standard gas price was bouncing between 5 and 7 on this website


that setup cost me 41 dollars for the second contract I think to get both through you are looking at maybe 60 to 70. anyway
the contract says success but the program didn’t put the address in the json file it was supposed to but that might have been because i was only deploying the flashloan as I already had the first contract deployed so i will trouble shoot that next. I hope that helps if you have any trouble or need to deploy one contract I found this site very helpful.

good luck