EatTheBlocks Forum

Mini-project "Multisig Wallet" - Expected Identifier, Got 'Payable' Issue

I have a problem on my Multisig Wallet test: Expected identifier, got Payable solc

I’m using Windows and VS Code. This is the second Multisig section from 6 Figure Blockchain Developer. I’m ready to test my wallet but get this error.

I’ve deleted all work and restarted the project with same result. Here’s my compiler:

I changed the name of my contract this time.

Additional:

Hey Travis, looks like VS Code does not use the correct version of Solidity and does not understand address payable type. You can ignore this error and only pay attention to the output of truffle test

I recently installed a few VS Code extensions. I uninstalled a few and it now works.

1 Like